summaryrefslogtreecommitdiff
path: root/dev-python/responses/responses-0.24.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/responses/responses-0.24.1.ebuild')
-rw-r--r--dev-python/responses/responses-0.24.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/responses/responses-0.24.1.ebuild b/dev-python/responses/responses-0.24.1.ebuild
deleted file mode 100644
index 3745618094dc..000000000000
--- a/dev-python/responses/responses-0.24.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Utility for mocking out the Python Requests library"
-HOMEPAGE="
- https://pypi.org/project/responses/
- https://github.com/getsentry/responses/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-# tomli backend is optional now, with pyyaml being the new default.
-# However, keeping it unconditional here for backwards compatibility.
-RDEPEND="
- dev-python/pyyaml[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- >=dev-python/requests-2.30.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.10)
- dev-python/tomli-w[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- test? (
- dev-python/pytest-httpserver[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -p pytest_httpserver
-}