summaryrefslogtreecommitdiff
path: root/dev-python/requests_download/requests_download-0.1.2-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests_download/requests_download-0.1.2-r2.ebuild')
-rw-r--r--dev-python/requests_download/requests_download-0.1.2-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/requests_download/requests_download-0.1.2-r2.ebuild b/dev-python/requests_download/requests_download-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..816f862190b5
--- /dev/null
+++ b/dev-python/requests_download/requests_download-0.1.2-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="
+ https://github.com/takluyver/requests_download
+ https://pypi.org/project/requests_download/
+"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )