summaryrefslogtreecommitdiff
path: root/dev-python/requests/requests-2.18.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests/requests-2.18.4-r1.ebuild')
-rw-r--r--dev-python/requests/requests-2.18.4-r1.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/requests/requests-2.18.4-r1.ebuild b/dev-python/requests/requests-2.18.4-r1.ebuild
deleted file mode 100644
index 44453c612cb3..000000000000
--- a/dev-python/requests/requests-2.18.4-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="http://python-requests.org/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="socks5 +ssl"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-2.7[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.23[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
- )
-"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-#DEPEND+="
-# test? (
-# dev-python/pytest[${PYTHON_USEDEP}]
-# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
-# dev-python/pytest-mock[${PYTHON_USEDEP}]
-# dev-python/pytest-xdist[${PYTHON_USEDEP}]
-# >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
-# )
-#"
-
-python_test() {
- py.test || die
-}