summaryrefslogtreecommitdiff
path: root/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild')
-rw-r--r--dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild b/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..c0761e977887
--- /dev/null
+++ b/dev-python/requests-ntlm/requests-ntlm-1.1.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/_}"
+
+DESCRIPTION="HTTP NTLM authentication using the requests library"
+HOMEPAGE="https://github.com/requests/requests-ntlm"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/ntlm-auth-1.0.2[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}