summaryrefslogtreecommitdiff
path: root/dev-python/requests-cache
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest4
-rw-r--r--dev-python/requests-cache/requests-cache-1.2.0.ebuild92
-rw-r--r--dev-python/requests-cache/requests-cache-1.2.1.ebuild4
3 files changed, 3 insertions, 97 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 724426a41c9b..f8eb71c3116f 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,5 +1,3 @@
-DIST requests-cache-1.2.0.gh.tar.gz 3057187 BLAKE2B 135d39d8fac1e123c71b07b30002b980b5fdcdb586cafb310f8f72e865cdc97f62b699cd981068207c6f020deef595469801d440cf5034566e9618385d569437 SHA512 b198d282cfd656c432d3a63f4d615191ac1ff97c9563e9bd6945e7a78444601108beb47a0f4a79740c7bd6942c3753f025cd52457e87ece7964229799bbb8fa1
DIST requests-cache-1.2.1.gh.tar.gz 3056882 BLAKE2B e1e5f971490f865ac2771d1dd87802ba138940adbfa0183ed5978b92794795fb26a30219de5560a925642ca08de1b8854d759408f86b30e6150e1c948ec8dcfe SHA512 f8977b1afc005ddd73019d2a0e39da368f376602110602c0b24c317b548f31a3489e686502ecd48ae3583e471fdd70671913e529c73dacdcaecadb1cd1e6c126
-EBUILD requests-cache-1.2.0.ebuild 2435 BLAKE2B 6239275238a62ca79d02b694f2929bce923f601fa4a1c704e697c8cce25d5dd6cc7dfa433204cf775bbbdacd364adb64df4d4b31c3364638da30b9212b8339f5 SHA512 f0bc5ca7b299ebe2abaa524e69d5a9c7af145d68da7ad4241caab3f0b63281f66518b0ce0c6674700cfaa13e58546ae796e2c075e7b7d6d313146920bdabe23e
-EBUILD requests-cache-1.2.1.ebuild 2440 BLAKE2B fd4dcd87bf09009ca0c7f5fb34c953356be59ad30ee0846da1c3d6c0d3d20d746205501acd829f34f306b68677c684c2d2fdf353ee1886cf50cef9f05170b652 SHA512 24528b10212b7646bc056dc6feb6f6e2820a212ca7408b703f832f670393488e6924aedeb24b0e08ad8cfd3935df9739fcc1f4975f6e1723dcf808210a8118d1
+EBUILD requests-cache-1.2.1.ebuild 2435 BLAKE2B 2071b05ebba9ad33e7748491e3834812e501c9f86bf96dbae20e0a82fa3d33e13859257d7bd59aefceba39cdb7d9b26723651e5bc99dc1e27ec26dd7720707da SHA512 05cd1f091f9f641aea56e9e534359e025aba753b10313b29a656a83b57dc0993d78762b28b7fa3b3e32ef4113d3ccc919672210fe39967160ae63a2f73f17f7d
MISC metadata.xml 541 BLAKE2B a8fd81921a36e2fe5bdec38cc1039b9e91971c992a59cbe2dc4826977f753bd6cd2533f65b5f1a076308a898972fe70e85a2c8cf480259e9801f51b10c4de8a4 SHA512 64f29b67eaf3ce892a9f918abd7eaf8f020323e9e0d986b424cffc83e3ac1ba5cb14b534f0a0ec73a8e81694ca4e0e7f98ef02968ac5b43dab104b2b12e8e0f2
diff --git a/dev-python/requests-cache/requests-cache-1.2.0.ebuild b/dev-python/requests-cache/requests-cache-1.2.0.ebuild
deleted file mode 100644
index cd7fa8425059..000000000000
--- a/dev-python/requests-cache/requests-cache-1.2.0.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Persistent cache for requests library"
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/requests-cache/requests-cache/
-"
-SRC_URI="
- https://github.com/requests-cache/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/attrs[${PYTHON_USEDEP}]
- >=dev-python/cattrs-22.2[${PYTHON_USEDEP}]
- >=dev-python/platformdirs-2.5[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- dev-python/urllib3[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/requests-mock[${PYTHON_USEDEP}]
- dev-python/responses[${PYTHON_USEDEP}]
- >=dev-python/rich-10.0[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- >=dev-python/ujson-5.4[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/time-machine[${PYTHON_USEDEP}]
- ' 'python*')
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_IGNORE=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
- )
- local EPYTEST_DESELECT=(
- # Requires Internet access
- tests/integration/test_upgrade.py::test_version_upgrade
- )
-
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # "database is locked", upstream probably relies on GC
- # too much
- tests/integration/test_sqlite.py
- )
- ;;
- python3.12)
- # https://github.com/requests-cache/requests-cache/issues/845
- EPYTEST_DESELECT+=(
- tests/integration/test_memory.py::TestMemoryCache::test_response_no_duplicate_read
- tests/integration/test_sqlite.py::TestSQLiteCache::test_concurrency
- )
- ;;
- esac
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest
-}
-
-pkg_postinst() {
- optfeature "redis backend" "dev-python/redis"
- optfeature "MongoDB backend" "dev-python/pymongo"
-
- optfeature "JSON serialization" "dev-python/ujson"
- optfeature "YAML serialization" "dev-python/pyyaml"
- optfeature "signing serialized data" "dev-python/itsdangerous"
-}
diff --git a/dev-python/requests-cache/requests-cache-1.2.1.ebuild b/dev-python/requests-cache/requests-cache-1.2.1.ebuild
index f7fcd8fb6ecb..8a5134989d01 100644
--- a/dev-python/requests-cache/requests-cache-1.2.1.ebuild
+++ b/dev-python/requests-cache/requests-cache-1.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1 optfeature
@@ -21,7 +21,7 @@ SRC_URI="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
RDEPEND="
dev-python/attrs[${PYTHON_USEDEP}]