summaryrefslogtreecommitdiff
path: root/dev-python/reno/reno-2.11.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reno/reno-2.11.2.ebuild')
-rw-r--r--dev-python/reno/reno-2.11.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/reno/reno-2.11.2.ebuild b/dev-python/reno/reno-2.11.2.ebuild
new file mode 100644
index 000000000000..699a74dcfdda
--- /dev/null
+++ b/dev-python/reno/reno-2.11.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"