summaryrefslogtreecommitdiff
path: root/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/reedsolomon/reedsolomon-1.6.0.ebuild')
-rw-r--r--dev-python/reedsolomon/reedsolomon-1.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild b/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild
new file mode 100644
index 000000000000..e5e8cdfe1f9c
--- /dev/null
+++ b/dev-python/reedsolomon/reedsolomon-1.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Reed Solomon encoder/decoder"
+HOMEPAGE="
+ https://github.com/tomerfiliba/reedsolomon/
+ https://pypi.org/project/reedsolo/
+"
+SRC_URI="
+ https://github.com/tomerfiliba/reedsolomon/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" tests/test_creedsolo.py || die "creedsolo test failed with ${EPYTHON}"
+ "${EPYTHON}" tests/test_reedsolo.py || die "reedsolo test failed with ${EPYTHON}"
+}