summaryrefslogtreecommitdiff
path: root/dev-python/redis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis')
-rw-r--r--dev-python/redis/Manifest4
-rw-r--r--dev-python/redis/redis-5.0.4.ebuild97
-rw-r--r--dev-python/redis/redis-5.0.5.ebuild2
3 files changed, 2 insertions, 101 deletions
diff --git a/dev-python/redis/Manifest b/dev-python/redis/Manifest
index 19e0cef02b41..1ba7a539bc53 100644
--- a/dev-python/redis/Manifest
+++ b/dev-python/redis/Manifest
@@ -1,7 +1,5 @@
-DIST redis-py-5.0.4.gh.tar.gz 4774815 BLAKE2B a6f3b678f217a7938d1a2ecbe24058994e33a7985faf0d4b6664aa08d5095c71dc9cd1d98ee327d6ff31589795eed29ece4cdd3ce914a782e60d3ac3f44ab962 SHA512 3c4893e348632d52215096358e5b4a86b3cf5e0153e4d218c46fe77fbb61df116fc98f477f4e8ba94fe7e9bb6f964f478b1187c8b7983a71fc206f14b643965c
DIST redis-py-5.0.5.gh.tar.gz 4775177 BLAKE2B e092692ca8070d811ccd953be2749859094baef610858fcc7f28fd18ec51e643cb0a003ddb5734e8066252e9beb49bdf633983906bb4615c0e8309389343aa2f SHA512 014c5bd9e7604cf757d990b1a0ad2d3c876822b1ee5b372eaa18cf26b5bf61bcdf6bd2d5e3f5eaa9e73de5dcc6a7ad11835856cb12c995a539961244e54c16fc
DIST redis-py-5.0.6.gh.tar.gz 4775649 BLAKE2B 7d6a7c10da592aed05fe70b1f0001697984c34244c29567755a13f0cb0d61db927f1392dd100212c88c63de52afbad2a9f17024d9af11f500db13386d080be2a SHA512 ae430e3c261bd8240bf1c736e28d066c685bb674dd6c2aabbf57bfa436027af31e59c2583777625ab3e1aa94f9b55a8e6513a94399c3aaec7e46b1128de8dd42
-EBUILD redis-5.0.4.ebuild 2717 BLAKE2B 5b30f28bfde630c04ea66476eb24aa60e87a621f9a8ec79a56ae678f94b00889cd12e72517d955e4251c3344fe14b550830cbf727b699fb54d46e00588fb92d8 SHA512 e4be9929feaf403a170837916196a46cf140ad75130c5d6ebecc62e282307f1f5c07c009d0f8df48f9344c998457f970c1641c2c2fc6c06e329575c704ae3b27
-EBUILD redis-5.0.5.ebuild 2723 BLAKE2B e4e9c34dbadf07efea78d11ebf767988315435a1590cae381de64df8d5ac58874a395d1bd20ec58116831f03b9c2636df5407e130b5d26bab9a0d60963120d11 SHA512 817b28f81e66935a77214c6a9b77f60c20a316fc5ccdda62d019ca132c17dd35ed2dc5206987299199bd0291d67357480d7ecbd1f0e9ccbf8d5359fac6400d10
+EBUILD redis-5.0.5.ebuild 2717 BLAKE2B 5b30f28bfde630c04ea66476eb24aa60e87a621f9a8ec79a56ae678f94b00889cd12e72517d955e4251c3344fe14b550830cbf727b699fb54d46e00588fb92d8 SHA512 e4be9929feaf403a170837916196a46cf140ad75130c5d6ebecc62e282307f1f5c07c009d0f8df48f9344c998457f970c1641c2c2fc6c06e329575c704ae3b27
EBUILD redis-5.0.6.ebuild 2723 BLAKE2B e4e9c34dbadf07efea78d11ebf767988315435a1590cae381de64df8d5ac58874a395d1bd20ec58116831f03b9c2636df5407e130b5d26bab9a0d60963120d11 SHA512 817b28f81e66935a77214c6a9b77f60c20a316fc5ccdda62d019ca132c17dd35ed2dc5206987299199bd0291d67357480d7ecbd1f0e9ccbf8d5359fac6400d10
MISC metadata.xml 506 BLAKE2B 0e5747e826132dd365bdf6d3a63f0936ed476bc69c4c4d55126e692039046f51f69b193ead0baa181090b11f69ab2a49220d8f906f9fe3fc18331b76ff9e0b0f SHA512 725d650bfe345b132588930a18ade44182ec07f6697d2fd8806dc208ab1556939926e8899fc6d43691101d971f9c1e011fb8a5675fdde4698dbf4c230db15c75
diff --git a/dev-python/redis/redis-5.0.4.ebuild b/dev-python/redis/redis-5.0.4.ebuild
deleted file mode 100644
index 615ccc4a50d9..000000000000
--- a/dev-python/redis/redis-5.0.4.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} pypy3 )
-
-inherit distutils-r1
-
-MY_P=redis-py-${PV}
-DESCRIPTION="Python client for Redis key-value store"
-HOMEPAGE="
- https://github.com/redis/redis-py/
- https://pypi.org/project/redis/
-"
-SRC_URI="
- https://github.com/redis/redis-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
- ' 3.10)
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Flaky test
- tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
- # require extra redis modules that apparently aren't packaged
- # on Gentoo
- tests/{,test_asyncio/}test_bloom.py
- tests/{,test_asyncio/}test_graph.py
- tests/{,test_asyncio/}test_json.py
- tests/{,test_asyncio/}test_timeseries.py
- # apparently available only in "Redis Stack 7.2 RC3 or later"
- tests/test_commands.py::TestRedisCommands::test_tfunction_load_delete
- tests/test_commands.py::TestRedisCommands::test_tfunction_list
- tests/test_commands.py::TestRedisCommands::test_tfcall
- # TODO
- tests/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_zrevrank_withscore
- tests/test_asyncio/test_commands.py::TestRedisCommands::test_xinfo_consumers
- tests/test_asyncio/test_pubsub.py::TestPubSubAutoReconnect::test_reconnect_socket_error[pool-hiredis-listen]
- )
-
- # TODO: try to run more servers?
- epytest -m "not redismod and not onlycluster and not replica and not ssl"
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- if has_version ">=dev-db/redis-7"; then
- local extra_conf="
- enable-debug-command yes
- enable-module-command yes
- "
- fi
-
- # Spawn Redis itself for testing purposes
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1 ::1
- ${extra_conf}
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/redis/redis-5.0.5.ebuild b/dev-python/redis/redis-5.0.5.ebuild
index 13bcaada0bb4..615ccc4a50d9 100644
--- a/dev-python/redis/redis-5.0.5.ebuild
+++ b/dev-python/redis/redis-5.0.5.ebuild
@@ -22,7 +22,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~riscv ~sparc x86"
RDEPEND="
$(python_gen_cond_dep '