summaryrefslogtreecommitdiff
path: root/dev-python/redis-py
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest8
-rw-r--r--dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch19
-rw-r--r--dev-python/redis-py/metadata.xml12
-rw-r--r--dev-python/redis-py/redis-py-2.10.5.ebuild65
-rw-r--r--dev-python/redis-py/redis-py-2.10.6.ebuild65
-rw-r--r--dev-python/redis-py/redis-py-2.9.1.ebuild64
6 files changed, 233 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
new file mode 100644
index 000000000000..53412dd97a5b
--- /dev/null
+++ b/dev-python/redis-py/Manifest
@@ -0,0 +1,8 @@
+AUX redis-py-2.10.5-test-finalize.patch 543 BLAKE2B 5bb883a674bee5fd4c7466a7a7b08473cf90540a7e78cdef53e425a0b5f3282dac06857b3269d0d3bcb602f716062d68cf7ddcf128b7934124cb778da5d60265 SHA512 bd1e48117d6ec89fcf86dde41b38deab3782e4e1ee6038123d3b225214b9843703067ca0d4b813d7bf8da1f64e45ff19a1b5a9337f2a9953a7f3ef9766b7a441
+DIST redis-py-2.10.5.tar.gz 88610 BLAKE2B 092efe4fcbc500a59981fc2d8574b70ee322ce7ccba012e5babd022f30abb017e53f093b3f4d876a297ab2e4403a57e749582d4027f1efa53efcbab0214347b7 SHA512 b2e6cb85c274c8f1c63e27256bbab816d016a68c324bf7092cf53feae819a34fa94f45565b0f209ee981919d793b2963462eb1a6f841e9dde9885802e0ebbe8f
+DIST redis-py-2.10.6.tar.gz 97299 BLAKE2B 9fea87b5c8ae0f3574651717e664cda62ca7752e44c4e60f4a50b82b53a52a5d005dc79c72afa58abfb807bf303f46335761129c54a2ef8e4f524451543c6c96 SHA512 e7df464bc3b26e23f6a0d2d2896306c1e4792b9a2a4ecaea6dd8690ffa17853cc85345f063307295dd3c2da399f7f203f4b21d785f7e073c0501732257419dad
+DIST redis-py-2.9.1.tar.gz 62204 BLAKE2B 633dd00d5aa984ac4dfb223aa685f8fa6913f4f00bb5c5c231dc77b6e8d33f1cd57c2e2bc07c4ec4658ca3b7675fd172919187fa2e95afb8eb5345f65dcbca00 SHA512 6b4912acafb31c87a5bc47b0420834aa9d1eba57feb0bbacdea943b746fe2f24aee4c9f13e7b03ae4edc562043b22c370cc7f53e45be07c5408cfa9852f8ea38
+EBUILD redis-py-2.10.5.ebuild 1454 BLAKE2B c645ec40e72632eabf747598f221d9e88394189f9dd392dd84162f02795af67b3b4c6badc92707bd8b7120f0288c95046b3aaf03c3e13788e3764e274764398f SHA512 7f38ee8032cec9ffc40554672fc29e53f8654747852c56b7a2f30bdb90cae865dc0c234fae8b95d6ad943f73714c9866fd06e0f35ed2cb38b990988293fa9079
+EBUILD redis-py-2.10.6.ebuild 1467 BLAKE2B b3e30cdf347a7f89ae92f15c95948a15f54b8fd84c6b13f9254f3ec3b80da25c4b38effb13189ae2a7bd11069a451cba01183755589beb54247507c83c0a18cb SHA512 48800bc3ccee6808fc18288eac74763346e0607ddceb151d8ef47229426d2b8afce1a22b3d28722bbbf96e673d23cffdaebccbda965dc33764c80b4877e6ca48
+EBUILD redis-py-2.9.1.ebuild 1527 BLAKE2B 51ff272cf07853883818688b8826950096f26f3e7c8c77e099c200498879c98ef2461e0d71339a2582a43f0366cdf4674eb3dff118dcb81bc5122e3c156fa387 SHA512 7eb014071ec90b685ad9f86a942e716b695e4f8dafb74faa259811021d2d272721722df883bf47ef9e130579c9ce3768fa26f3ce19175d10b64f2e93339131dd
+MISC metadata.xml 380 BLAKE2B 993e671ed9c6a9649a8dc0d95207b4dc1f90cb38eb8af6e470fc9e18b496768b541c033ee961957d56ee93b335c54447b741fad38f71498188480822350b508b SHA512 5e03d25770ee53beb71d1efa039401a5598572bbf6cd441c904fb5c074d212c0c05934c6f86abb566e913ac65bd84db3cdaca8b83c182dad57d0fcffdeb9aa4b
diff --git a/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch b/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch
new file mode 100644
index 000000000000..1a807480dfb0
--- /dev/null
+++ b/dev-python/redis-py/files/redis-py-2.10.5-test-finalize.patch
@@ -0,0 +1,19 @@
+ setup.py | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index ed8fd5f..ab648a3 100644
+--- a/setup.py
++++ b/setup.py
+@@ -9,11 +9,6 @@ try:
+ from setuptools.command.test import test as TestCommand
+
+ class PyTest(TestCommand):
+- def finalize_options(self):
+- TestCommand.finalize_options(self)
+- self.test_args = []
+- self.test_suite = True
+-
+ def run_tests(self):
+ # import here, because outside the eggs aren't loaded
+ import pytest
diff --git a/dev-python/redis-py/metadata.xml b/dev-python/redis-py/metadata.xml
new file mode 100644
index 000000000000..521781f755ca
--- /dev/null
+++ b/dev-python/redis-py/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">redis</remote-id>
+ <remote-id type="github">andymccurdy/redis-py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/redis-py/redis-py-2.10.5.ebuild b/dev-python/redis-py/redis-py-2.10.5.ebuild
new file mode 100644
index 000000000000..f0f244bd48ce
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.10.5.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="https://github.com/andymccurdy/redis-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-db/redis
+ >=dev-python/pytest-2.5.0[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-test-finalize.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Make sure that tests will be used from BUILD_DIR rather than cwd.
+ mv tests tests-hidden || die
+
+ # Correct local import patch syntax
+ sed -e 's:from .conftest:from conftest:' \
+ -i tests-hidden/{test_connection_pool.py,test_commands.py,test_encoding.py,test_pubsub.py} \
+ || die
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use test; then
+ cp -r tests-hidden "${BUILD_DIR}"/tests || die
+ fi
+}
+
+python_test() {
+ local sock="${T}/redis.sock"
+
+ "${EPREFIX}/usr/sbin/redis-server" - <<- EOF
+ daemonize yes
+ pidfile "${T}/redis.pid"
+ unixsocket ${sock}
+ EOF
+
+ PYTHONPATH="${S}:${S}/tests-hidden"
+ esetup.py test --verbose
+ kill $(<"${T}/redis.pid")
+}
diff --git a/dev-python/redis-py/redis-py-2.10.6.ebuild b/dev-python/redis-py/redis-py-2.10.6.ebuild
new file mode 100644
index 000000000000..b129427e76e6
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.10.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="https://github.com/andymccurdy/redis-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-db/redis
+ >=dev-python/pytest-2.5.0[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.10.5-test-finalize.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Make sure that tests will be used from BUILD_DIR rather than cwd.
+ mv tests tests-hidden || die
+
+ # Correct local import patch syntax
+ sed -e 's:from .conftest:from conftest:' \
+ -i tests-hidden/{test_connection_pool.py,test_commands.py,test_encoding.py,test_pubsub.py} \
+ || die
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use test; then
+ cp -r tests-hidden "${BUILD_DIR}"/tests || die
+ fi
+}
+
+python_test() {
+ local sock="${T}/redis.sock"
+
+ "${EPREFIX}/usr/sbin/redis-server" - <<- EOF
+ daemonize yes
+ pidfile "${T}/redis.pid"
+ unixsocket ${sock}
+ EOF
+
+ PYTHONPATH="${S}:${S}/tests-hidden"
+ esetup.py test --verbose
+ kill $(<"${T}/redis.pid")
+}
diff --git a/dev-python/redis-py/redis-py-2.9.1.ebuild b/dev-python/redis-py/redis-py-2.9.1.ebuild
new file mode 100644
index 000000000000..c10e206a69e6
--- /dev/null
+++ b/dev-python/redis-py/redis-py-2.9.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+MY_PN="redis"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="https://github.com/andymccurdy/redis-py"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-db/redis )"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Disable pubsub and encoding tests, they do not seem to support
+ # UNIX socket connectivity.
+ sed -i -e '/PubSub/d' -e '/Encoding/d' \
+ -e '/use_hiredis:/d' tests/__init__.py || die
+
+ # Make sure that tests will be used from BUILD_DIR rather than cwd.
+ mv tests tests-hidden || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ if use test; then
+ cp -r tests-hidden "${BUILD_DIR}"/tests || die
+ fi
+}
+
+python_test() {
+ local pidfile=${T}/redis-${EPYTHON}.pid
+ local sock=${T}/redis-${EPYTHON}.sock
+
+ sed -i -e "s:port=6379:unix_socket_path=\"${sock}\":" \
+ "${BUILD_DIR}"/tests/*.py || die
+
+ # XXX: find a way to make sure it is killed
+
+ "${EPREFIX}"/usr/sbin/redis-server \
+ --pidfile "${pidfile}" \
+ --port 0 \
+ --unixsocket "${sock}" \
+ --daemonize yes || die
+ PYTHONPATH="${PYTHONPATH}:${BUILD_DIR}" \
+ esetup.py test
+ kill "$(<"${pidfile}")"
+}