summaryrefslogtreecommitdiff
path: root/dev-python/redis-py/redis-py-3.5.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/redis-py/redis-py-3.5.3.ebuild')
-rw-r--r--dev-python/redis-py/redis-py-3.5.3.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/redis-py/redis-py-3.5.3.ebuild b/dev-python/redis-py/redis-py-3.5.3.ebuild
index b23499651afc..6954d82304d8 100644
--- a/dev-python/redis-py/redis-py-3.5.3.ebuild
+++ b/dev-python/redis-py/redis-py-3.5.3.ebuild
@@ -13,10 +13,11 @@ MY_P="${MY_PN}-${PV}"
DESCRIPTION="Python client for Redis key-value store"
HOMEPAGE="https://github.com/andymccurdy/redis-py"
SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="test"
RESTRICT="!test? ( test )"
@@ -27,8 +28,6 @@ DEPEND="
)
"
-S="${WORKDIR}/${MY_P}"
-
python_prepare_all() {
distutils-r1_python_prepare_all
@@ -54,10 +53,11 @@ python_compile() {
src_test() {
local redis_pid="${T}"/redis.pid
local redis_port=6379
- local redis_test_config="daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
+ local redis_test_config="
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
"
# Spawn Redis itself for testing purposes
@@ -65,7 +65,7 @@ src_test() {
# I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
elog "Spawning Redis"
elog "NOTE: Port ${redis_port} must be free"
- /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+ "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
# Run the tests
distutils-r1_src_test