summaryrefslogtreecommitdiff
path: root/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild')
-rw-r--r--dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild19
1 files changed, 17 insertions, 2 deletions
diff --git a/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild b/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
index 9761a3e670ef..73dd01dd89d1 100644
--- a/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
+++ b/dev-python/recommonmark/recommonmark-0.7.1-r1.ebuild
@@ -8,8 +8,15 @@ PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1
DESCRIPTION="Python docutils-compatibility bridge to CommonMark"
-HOMEPAGE="https://recommonmark.readthedocs.io/"
-SRC_URI="https://github.com/rtfd/recommonmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="
+ https://recommonmark.readthedocs.io/
+ https://github.com/readthedocs/recommonmark/
+ https://pypi.org/project/recommonmark/
+"
+SRC_URI="
+ https://github.com/readthedocs/recommonmark/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -26,4 +33,12 @@ PATCHES=(
"${FILESDIR}/${PN}-0.6.0-sphinx3-2.patch"
)
+# These tests are sensitive to Sphinx formatting changes and they will never
+# get fixed because upstream has archived the project in favor of myst_parser.
+# Bug #866009
+EPYTEST_DESELECT=(
+ "tests/test_sphinx.py::GenericTests::test_headings"
+ "tests/test_sphinx.py::CustomExtensionTests::test_integration"
+)
+
distutils_enable_tests pytest