summaryrefslogtreecommitdiff
path: root/dev-python/ratelimit/ratelimit-1.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ratelimit/ratelimit-1.4.1.ebuild')
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
index 3c01b8f2c100..e91d5f08f03e 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,11 +16,14 @@ KEYWORDS="~amd64 ~x86"
IUSE="test"
DEPEND="
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )"
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+src_prepare() {
+ default
+ # remove --cov args injection
+ rm pytest.ini || die
+}
python_test() {
- py.test || die
+ pytest || die
}