summaryrefslogtreecommitdiff
path: root/dev-python/rarfile/rarfile-4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rarfile/rarfile-4.2.ebuild')
-rw-r--r--dev-python/rarfile/rarfile-4.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/rarfile/rarfile-4.2.ebuild b/dev-python/rarfile/rarfile-4.2.ebuild
new file mode 100644
index 000000000000..e2083fd03329
--- /dev/null
+++ b/dev-python/rarfile/rarfile-4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="
+ https://github.com/markokr/rarfile/
+ https://pypi.org/project/rarfile/
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+compressed test"
+REQUIRED_USE="test? ( compressed )"
+
+RDEPEND="
+ compressed? ( app-arch/unrar )
+"
+
+distutils_enable_tests pytest