summaryrefslogtreecommitdiff
path: root/dev-python/rapidfuzz
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rapidfuzz')
-rw-r--r--dev-python/rapidfuzz/Manifest4
-rw-r--r--dev-python/rapidfuzz/metadata.xml2
-rw-r--r--dev-python/rapidfuzz/rapidfuzz-3.6.2.ebuild66
3 files changed, 70 insertions, 2 deletions
diff --git a/dev-python/rapidfuzz/Manifest b/dev-python/rapidfuzz/Manifest
index ca3b55368981..11181d80634d 100644
--- a/dev-python/rapidfuzz/Manifest
+++ b/dev-python/rapidfuzz/Manifest
@@ -1,3 +1,5 @@
DIST rapidfuzz-3.6.1.tar.gz 1559239 BLAKE2B 50d2b2f1b1a62ad1a0a4a2300977d990a484f0a8033da6dd37531a5b603c0b28fe9a1a0e590ca9dc96bd57412864b50cf7694529127e9d26f5ef35daca6c0786 SHA512 17b40c9c3f94277340568f32ef121b277882e9191ad445df930cb394adb47bc4207008932550e74990af0d284c7af00e8ea3003114113a109a629117ebd9859c
+DIST rapidfuzz-3.6.2.tar.gz 1556623 BLAKE2B aef59f1d03309535015e0fb27688613630c0e2c459f464223d4ef8dbbb0241f991ae2b9c9d81890f7cd063f33ad7e6193a6f9c98c5287010402b402e1f343b1e SHA512 83ba27ec1c68d10c568ee629519709113aac3136e73da55d46dcfd3b0f1eac2ebe8631376ca10d2b5fde892d690d79f5a8ce5fd0114502d1f3576756b0960db7
EBUILD rapidfuzz-3.6.1.ebuild 1631 BLAKE2B c1b64729dbd5d9f26e5185ed30bdf03da34ac586d60a880624922370d80b443f90c2edbd7a6ef1b42ca736f029dc82fb6e11258dd8e61f7da20d8295a3b015eb SHA512 0abc079bf4b26f3a39434519e49678673a5e177f967ac7ddcc188bc977996a5ee42028962a4252628105121d75fdb576e583d835a7ce8a6f1ae48173e7165d9a
-MISC metadata.xml 374 BLAKE2B e6ee89a9850276b8c22c9bc851ebea2cde2ea696d122d70c6465e09a9371c59f81d1976b3253e8ee90afae5e3e30e993481b402058bac0c58ec01f71a0b7c3b4 SHA512 9a39c4bcf8e8de0a6d6a356a9aeb415f8f49667caf5716eee50bf251f1fd53bb076e817fac0b15bf64e65c1b9625c78810da61a5d96b273a20b2669a18084d6e
+EBUILD rapidfuzz-3.6.2.ebuild 1636 BLAKE2B 05b0140e907e45c2e54c873cffc6f8b12f36acd5d61b72f0c0d492163a3ce58809395ffea45bbc0ac445b85951a600c776af46b5e2a8e147a3e387e43e5eba68 SHA512 0fb0fe112b49ca1a9713bd03afb83590a5aba9960b06e4ea5c80a14168603ba4a12dc3d60400fd04e097b7a29dd3dc7a48c942e21aaf4ab30e83831ef893054e
+MISC metadata.xml 372 BLAKE2B 79ce98b986a4193ec72cfc1ef0a1e1970e2e6333da3dc0abdc24de4148932c4f81e68a4d85cedf308d79ee5fe61c1d2573889fe4f89025b7b4848caf4380596c SHA512 014b2de4c7eb3976799f76ca01c59585be12ff0718cb8378ce0aabf40113d8fd402e0a8ef26fd8924ee0840fa7e99677e5e31698180a0537a0627c464c29e34e
diff --git a/dev-python/rapidfuzz/metadata.xml b/dev-python/rapidfuzz/metadata.xml
index 91cac0023d89..e69b40da9b2f 100644
--- a/dev-python/rapidfuzz/metadata.xml
+++ b/dev-python/rapidfuzz/metadata.xml
@@ -6,7 +6,7 @@
<name>Python</name>
</maintainer>
<upstream>
- <remote-id type="github">maxbachmann/RapidFuzz</remote-id>
+ <remote-id type="github">rapidfuzz/RapidFuzz</remote-id>
<remote-id type="pypi">rapidfuzz</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/rapidfuzz/rapidfuzz-3.6.2.ebuild b/dev-python/rapidfuzz/rapidfuzz-3.6.2.ebuild
new file mode 100644
index 000000000000..07d8d11d86eb
--- /dev/null
+++ b/dev-python/rapidfuzz/rapidfuzz-3.6.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+# custom wrapper over setuptools
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Rapid fuzzy string matching in Python using various string metrics"
+HOMEPAGE="
+ https://github.com/rapidfuzz/RapidFuzz/
+ https://pypi.org/project/rapidfuzz/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# all these are header-only libraries
+DEPEND="
+ >=dev-cpp/taskflow-3.0.0
+ >=dev-cpp/rapidfuzz-cpp-3.0.2
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ dev-python/rapidfuzz-capi[${PYTHON_USEDEP}]
+ >=dev-python/scikit-build-0.16.2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # sterilize build flags
+ sed -i -e '/CMAKE_INTERPROCEDURAL_OPTIMIZATION/d' CMakeLists.txt || die
+ # remove bundled libraries
+ rm -r extern || die
+ # force recythonization
+ find src -name '*.cxx' -delete || die
+
+ distutils-r1_src_prepare
+
+ export RAPIDFUZZ_BUILD_EXTENSION=1
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # scikit-build is broken and reuses the same build
+ # https://github.com/scikit-build/scikit-build/issues/633
+ rm -r _skbuild || die
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}