summaryrefslogtreecommitdiff
path: root/dev-python/random2/random2-1.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/random2/random2-1.0.1-r2.ebuild')
-rw-r--r--dev-python/random2/random2-1.0.1-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/random2/random2-1.0.1-r2.ebuild b/dev-python/random2/random2-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..2a366d4c7b1b
--- /dev/null
+++ b/dev-python/random2/random2-1.0.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python-2.7 random module ported to python-3"
+HOMEPAGE="https://pypi.org/project/random2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="app-arch/unzip"
+
+distutils_enable_tests setup.py
+
+PATCHES=( "${FILESDIR}/${P}-py39-tests.patch" )