summaryrefslogtreecommitdiff
path: root/dev-python/random2/random2-1.0.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/random2/random2-1.0.1-r2.ebuild')
-rw-r--r--dev-python/random2/random2-1.0.1-r2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-python/random2/random2-1.0.1-r2.ebuild b/dev-python/random2/random2-1.0.1-r2.ebuild
index b7e06f096120..22d0334374a0 100644
--- a/dev-python/random2/random2-1.0.1-r2.ebuild
+++ b/dev-python/random2/random2-1.0.1-r2.ebuild
@@ -6,18 +6,22 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
+inherit distutils-r1 pypi
DESCRIPTION="Python-2.7 random module ported to python-3"
HOMEPAGE="https://pypi.org/project/random2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+SRC_URI="$(pypi_sdist_url "${PN}" "${PV}" .zip)"
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="amd64 arm64 ~riscv x86"
-BDEPEND="app-arch/unzip"
+BDEPEND="
+ app-arch/unzip
+"
distutils_enable_tests setup.py
-PATCHES=( "${FILESDIR}/${P}-py39-tests.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-py39-tests.patch"
+)