summaryrefslogtreecommitdiff
path: root/dev-python/random2/random2-1.0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/random2/random2-1.0.1-r1.ebuild')
-rw-r--r--dev-python/random2/random2-1.0.1-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/random2/random2-1.0.1-r1.ebuild b/dev-python/random2/random2-1.0.1-r1.ebuild
index 0139d75a0051..9b405d64d602 100644
--- a/dev-python/random2/random2-1.0.1-r1.ebuild
+++ b/dev-python/random2/random2-1.0.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
DESCRIPTION="Python-2.7 random module ported to python-3"
@@ -14,8 +14,7 @@ LICENSE="PSF-2"
SLOT="0"
KEYWORDS="amd64 arm64 x86"
-BDEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="app-arch/unzip"
distutils_enable_tests setup.py