summaryrefslogtreecommitdiff
path: root/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild')
-rw-r--r--dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild b/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
deleted file mode 100644
index 56171eb5b114..000000000000
--- a/dev-python/ramlfications/ramlfications-0.1.9_p20160718.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6)
-
-COMMIT="32a11cd7d75c4c5b3e3fc01c383314be298b0f9b"
-
-inherit eutils distutils-r1
-
-DESCRIPTION="RAML reference implementation in Python"
-HOMEPAGE="https://ramlfications.readthedocs.org/ https://pypi.org/project/ramlfications/"
-SRC_URI="https://github.com/spotify/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/markdown2[${PYTHON_USEDEP}]
- dev-python/jsonref[${PYTHON_USEDEP}]
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/attrs[${PYTHON_USEDEP}]
- dev-python/termcolor[${PYTHON_USEDEP}]
- dev-python/xmltodict[${PYTHON_USEDEP}]
-"
-DEPEND="
- ${RDEPEND}
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-localserver[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}