summaryrefslogtreecommitdiff
path: root/dev-python/quart/quart-0.19.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/quart/quart-0.19.4.ebuild')
-rw-r--r--dev-python/quart/quart-0.19.4.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/quart/quart-0.19.4.ebuild b/dev-python/quart/quart-0.19.4.ebuild
deleted file mode 100644
index 8f88cb4d2002..000000000000
--- a/dev-python/quart/quart-0.19.4.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python ASGI web microframework with the same API as Flask"
-HOMEPAGE="
- https://github.com/pallets/quart/
- https://pypi.org/project/Quart/
-"
-# no tests in sdist as of 0.19.4
-SRC_URI="
- https://github.com/pallets/quart/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86"
-
-RDEPEND="
- dev-python/aiofiles[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.6[${PYTHON_USEDEP}]
- >=dev-python/click-8.0.0[${PYTHON_USEDEP}]
- >=dev-python/flask-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/hypercorn-0.11.2[${PYTHON_USEDEP}]
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- dev-python/jinja[${PYTHON_USEDEP}]
- dev-python/markupsafe[${PYTHON_USEDEP}]
- >=dev-python/werkzeug-3.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/python-dotenv[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -o addopts= -p asyncio
-}