summaryrefslogtreecommitdiff
path: root/dev-python/qtsass/qtsass-0.3.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qtsass/qtsass-0.3.2.ebuild')
-rw-r--r--dev-python/qtsass/qtsass-0.3.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/qtsass/qtsass-0.3.2.ebuild b/dev-python/qtsass/qtsass-0.3.2.ebuild
new file mode 100644
index 000000000000..295f07dc7a26
--- /dev/null
+++ b/dev-python/qtsass/qtsass-0.3.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Compile SASS files to Qt stylesheets"
+HOMEPAGE="https://github.com/spyder-ide/qtsass"
+SRC_URI="https://github.com/spyder-ide/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/libsass[${PYTHON_USEDEP}]"
+
+BDEPEND="test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest