summaryrefslogtreecommitdiff
path: root/dev-python/qstylizer
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qstylizer')
-rw-r--r--dev-python/qstylizer/Manifest4
-rw-r--r--dev-python/qstylizer/metadata.xml1
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.2.ebuild36
3 files changed, 22 insertions, 19 deletions
diff --git a/dev-python/qstylizer/Manifest b/dev-python/qstylizer/Manifest
index c01cbc3099fc..c49d987555f3 100644
--- a/dev-python/qstylizer/Manifest
+++ b/dev-python/qstylizer/Manifest
@@ -1,3 +1,3 @@
DIST qstylizer-0.2.2.gh.tar.gz 20752 BLAKE2B c5442821389863bc03bb0659b528322cc12f5be8137f74746e3ec7a18bf89d2822d533d13cc23842daf32a0077ad84d0e7b5dc62f231e75e57388064bd08e5fc SHA512 682f10462965a93b36f0e44b75885b9d60b4d3cd03369976b977c9b928afed4e930b6b7ef26850bdb7b40ef2a31db35a9778738582dae8715f54c1f00a957fb3
-EBUILD qstylizer-0.2.2.ebuild 1572 BLAKE2B a55192f674209a3dbe352bd8ff144811e41dbfbe708d89c6d93ccce0a8d4ceefdd33043fae35b01243f4826bca5ee448d6bfcbf770b5509f7c9d059c652baedf SHA512 2ea6f9db5503812f69ba403ecc4fa81f10d527feb2b89d9f0d43d03365b20d5b45e35698841a3bc73759b92a5f69f8ed00cba2c944beab298d111fc72e1ec4a4
-MISC metadata.xml 355 BLAKE2B bbd0a92b969f24330e934a3fb9db82c99d4e0f4daeb6a4fadaa5cefa0caa2d4eab393f2743664ea7bf685df3deed81ffd3e4eb8f12089d395c4c6b231bec9d58 SHA512 504b904577a9f891df117d1ca79a0041463cef7fcadb8c2dbfcf2f88abf2c26bc08a976dff5d8e51a563d6a6070b354fa2c1918051aeccf3ea5a359a3ea04694
+EBUILD qstylizer-0.2.2.ebuild 1204 BLAKE2B 21fcc9d70d42fe9d04701b19cb1a9b01d125799d82849589f9fd9f94ea04442928db43fcde055e08593b8622edaaaf447c74a4e862c303943eb2f7f3e03c2f79 SHA512 6d2ac0254c769b4cf24e80229af85f044b20964cee3fbef4d7da62fdf4ff36fc673d9df0198ee1d6e0274cb5b83dc7025e42b795bf9462448ffb48540b063895
+MISC metadata.xml 415 BLAKE2B 451dfb7201a39eb121ef90a7c2ebb89dac9efffa47c7fe9b7470b8bdfe50e9fa0355fd6a16755423c067436e1a9777a7e36ccc4e0ea85f9b40fba1abf03dc590 SHA512 926ce3660ca54d4678987b339506daa3af21c49acedf474c1bbe3a5b79864d27f56867eeacd02bcdca312cf1edadc0bd9889c691414ba504c447aff0a2b6060e
diff --git a/dev-python/qstylizer/metadata.xml b/dev-python/qstylizer/metadata.xml
index 23e6ac5d4bb5..0b45c41cc38c 100644
--- a/dev-python/qstylizer/metadata.xml
+++ b/dev-python/qstylizer/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">blambright/qstylizer</remote-id>
<remote-id type="pypi">qstylizer</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/qstylizer/qstylizer-0.2.2.ebuild b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
index 35ecfee16349..e7bb30029705 100644
--- a/dev-python/qstylizer/qstylizer-0.2.2.ebuild
+++ b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
-HOMEPAGE="https://github.com/blambright/qstylizer"
-SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/blambright/qstylizer/
+ https://pypi.org/project/qstylizer/
+"
+SRC_URI="
+ https://github.com/blambright/qstylizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -24,7 +31,6 @@ RDEPEND="
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
- dev-vcs/git
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
@@ -32,21 +38,17 @@ BDEPEND="
"
distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx-rtd-theme dev-python/sphinxcontrib-autoprogram
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-autoprogram
python_prepare_all() {
- # Exception: Versioning for this project requires either an sdist tarball, or access to an
- # upstream git repository. It's also possible that there is a mismatch between the package
- # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
- # was given, but was not able to be found.
- #
- # There are no tarballs on PyPI, so we do this as a workaround
- git init -q || die
- git config user.email "larry@gentoo.org" || die
- git config user.name "Larry the Cow" || die
- git add . || die
- git commit -m "init" || die
- git tag -a "${PV}" -m "${PV}" || die
+ # fix test
+ # https://github.com/blambright/qstylizer/pull/17
+ sed -e 's:[.]called_once_with:.assert_called_once_with:' \
+ -i test/unit/test_style.py || die
distutils-r1_python_prepare_all
+
+ export PBR_VERSION=${PV}
}