summaryrefslogtreecommitdiff
path: root/dev-python/qstylizer/qstylizer-0.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qstylizer/qstylizer-0.2.2.ebuild')
-rw-r--r--dev-python/qstylizer/qstylizer-0.2.2.ebuild36
1 files changed, 19 insertions, 17 deletions
diff --git a/dev-python/qstylizer/qstylizer-0.2.2.ebuild b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
index 35ecfee16349..e7bb30029705 100644
--- a/dev-python/qstylizer/qstylizer-0.2.2.ebuild
+++ b/dev-python/qstylizer/qstylizer-0.2.2.ebuild
@@ -3,13 +3,20 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit distutils-r1
DESCRIPTION="Stylesheet Generator for PyQt5/PySide2"
-HOMEPAGE="https://github.com/blambright/qstylizer"
-SRC_URI="https://github.com/blambright/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/blambright/qstylizer/
+ https://pypi.org/project/qstylizer/
+"
+SRC_URI="
+ https://github.com/blambright/qstylizer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -24,7 +31,6 @@ RDEPEND="
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
- dev-vcs/git
test? (
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
@@ -32,21 +38,17 @@ BDEPEND="
"
distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx-rtd-theme dev-python/sphinxcontrib-autoprogram
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme \
+ dev-python/sphinxcontrib-autoprogram
python_prepare_all() {
- # Exception: Versioning for this project requires either an sdist tarball, or access to an
- # upstream git repository. It's also possible that there is a mismatch between the package
- # name in setup.cfg and the argument given to pbr.version.VersionInfo. Project name qstylizer
- # was given, but was not able to be found.
- #
- # There are no tarballs on PyPI, so we do this as a workaround
- git init -q || die
- git config user.email "larry@gentoo.org" || die
- git config user.name "Larry the Cow" || die
- git add . || die
- git commit -m "init" || die
- git tag -a "${PV}" -m "${PV}" || die
+ # fix test
+ # https://github.com/blambright/qstylizer/pull/17
+ sed -e 's:[.]called_once_with:.assert_called_once_with:' \
+ -i test/unit/test_style.py || die
distutils-r1_python_prepare_all
+
+ export PBR_VERSION=${PV}
}