summaryrefslogtreecommitdiff
path: root/dev-python/qrcode/qrcode-7.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qrcode/qrcode-7.4.2.ebuild')
-rw-r--r--dev-python/qrcode/qrcode-7.4.2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/qrcode/qrcode-7.4.2.ebuild b/dev-python/qrcode/qrcode-7.4.2.ebuild
new file mode 100644
index 000000000000..03f7ce68a631
--- /dev/null
+++ b/dev-python/qrcode/qrcode-7.4.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="
+ https://github.com/lincolnloop/python-qrcode/
+ https://pypi.org/project/qrcode/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1.0[${PYTHON_USEDEP}]
+ dev-python/pypng[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # TODO
+ qrcode/tests/test_script.py::ScriptTest::test_factory
+)
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}