summaryrefslogtreecommitdiff
path: root/dev-python/qrcode/qrcode-7.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/qrcode/qrcode-7.4.2.ebuild')
-rw-r--r--dev-python/qrcode/qrcode-7.4.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/qrcode/qrcode-7.4.2.ebuild b/dev-python/qrcode/qrcode-7.4.2.ebuild
index e6552ddb95b1..dc11be3a4569 100644
--- a/dev-python/qrcode/qrcode-7.4.2.ebuild
+++ b/dev-python/qrcode/qrcode-7.4.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -32,6 +32,8 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
# TODO
qrcode/tests/test_script.py::ScriptTest::test_factory
+ # release process-specific tests, broken on py3.12
+ qrcode/tests/test_release.py
)
src_install() {