summaryrefslogtreecommitdiff
path: root/dev-python/pyzmq/pyzmq-14.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyzmq/pyzmq-14.4.1.ebuild')
-rw-r--r--dev-python/pyzmq/pyzmq-14.4.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-python/pyzmq/pyzmq-14.4.1.ebuild b/dev-python/pyzmq/pyzmq-14.4.1.ebuild
deleted file mode 100644
index f83f0a659620..000000000000
--- a/dev-python/pyzmq/pyzmq-14.4.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="http://www.zeromq.org/bindings:python https://pypi.python.org/pypi/pyzmq"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples green test"
-
-# Ensures installation of gevent for test phase
-REQUIRED_USE="test? ( green )"
-
-PY2_USEDEP=$(python_gen_usedep python2_7)
-RDEPEND=">=net-libs/zeromq-2.1.9:=
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
- green? ( dev-python/gevent[${PY2_USEDEP}] )"
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? (
- dev-python/sphinx[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )"
-
-python_configure_all() {
- tc-export CC
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- distutils-r1_python_compile
-}
-
-python_test() {
- if python_is_python3; then
- einfo "Skipping python3 due to lack of support by gevent"
- else
- nosetests -svw "${BUILD_DIR}/lib/"
- fi
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- use doc && local HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}