summaryrefslogtreecommitdiff
path: root/dev-python/pywinrm/pywinrm-0.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pywinrm/pywinrm-0.4.2.ebuild')
-rw-r--r--dev-python/pywinrm/pywinrm-0.4.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pywinrm/pywinrm-0.4.2.ebuild b/dev-python/pywinrm/pywinrm-0.4.2.ebuild
new file mode 100644
index 000000000000..d5323322e7ba
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Windows Remote Management (WinRM) service"
+HOMEPAGE="https://github.com/diyan/pywinrm/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kerberos"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ kerberos? (
+ <dev-python/pykerberos-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest