summaryrefslogtreecommitdiff
path: root/dev-python/pyusb/pyusb-1.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyusb/pyusb-1.0.2.ebuild')
-rw-r--r--dev-python/pyusb/pyusb-1.0.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyusb/pyusb-1.0.2.ebuild b/dev-python/pyusb/pyusb-1.0.2.ebuild
new file mode 100644
index 000000000000..abedff611616
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://walac.github.io/pyusb/ https://pypi.python.org/pypi/pyusb"
+SRC_URI="https://github.com/walac/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+# pypi releases don't include tests
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:=
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="README.rst docs/tutorial.rst"
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}