summaryrefslogtreecommitdiff
path: root/dev-python/pyupgrade/pyupgrade-2.38.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyupgrade/pyupgrade-2.38.0.ebuild')
-rw-r--r--dev-python/pyupgrade/pyupgrade-2.38.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyupgrade/pyupgrade-2.38.0.ebuild b/dev-python/pyupgrade/pyupgrade-2.38.0.ebuild
new file mode 100644
index 000000000000..eb59646e97ec
--- /dev/null
+++ b/dev-python/pyupgrade/pyupgrade-2.38.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Tool + pre-commit hook to automatically upgrade syntax for newer Pythons"
+HOMEPAGE="https://github.com/asottile/pyupgrade"
+SRC_URI="https://github.com/asottile/pyupgrade/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/tokenize-rt[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest