summaryrefslogtreecommitdiff
path: root/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild')
-rw-r--r--dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild b/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
index 9c1929203e47..43d950f052e0 100644
--- a/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
+++ b/dev-python/pyu2f/pyu2f-0.1.5-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -39,12 +39,15 @@ DOCS=( CONTRIBUTING.md README.md )
distutils_enable_tests pytest
python_prepare_all() {
- # adjust pyfakefs usage #888223
+ # https://github.com/google/pyu2f/commit/5e2f862dd5ba61eadff341dbf0a1202e91b1b145
+ sed -i -e 's:logger[.]warn:&ing:' pyu2f/hid/macos.py || die
sed -e "s:CreateFile:create_file:" \
-e "s:CreateDirectory:create_dir:" \
-e "s:RemoveObject:remove_object:" \
-e "s:SetContents:set_contents:" \
-i pyu2f/tests/hid/linux_test.py || die
+ # https://github.com/google/pyu2f/commit/793acd9ff6612bb035f0724b04e10a01cdb5bb8d
+ # https://github.com/google/pyu2f/commit/dad654010a030f1038bd2df95a9647fb417e0447
find pyu2f/tests -name '*.py' -exec \
sed -e 's:assertEquals:assertEqual:' \
-e 's:assertRaisesRegexp:assertRaisesRegex:' \