summaryrefslogtreecommitdiff
path: root/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild')
-rw-r--r--dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild b/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild
deleted file mode 100644
index 3361d4f9f406..000000000000
--- a/dev-python/pyu2f/pyu2f-0.1.4-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python based U2F host library"
-HOMEPAGE="https://github.com/google/pyu2f"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- ${RDEPEND}
- test? (
- dev-python/pyfakefs[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CONTRIBUTING.md README.md )
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's:json.loads(communicate_json):json.loads(communicate_json.decode()):' \
- -i pyu2f/tests/customauthenticator_test.py || die
-
- distutils-r1_python_prepare_all
-}