summaryrefslogtreecommitdiff
path: root/dev-python/pytz
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/Manifest3
-rw-r--r--dev-python/pytz/files/pytz-2020.5-system-zoneinfo.patch33
-rw-r--r--dev-python/pytz/pytz-2020.5.ebuild32
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index d60fc69a14be..994353998c62 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,5 +1,8 @@
AUX 2018.4-zoneinfo.patch 549 BLAKE2B 5654ac8133627afaf9dc17dd9ae8e6a22ef9206efc6ca88495bfdec0078fc77a290ab7a62d6d1aa722ac01b9428bf37382d5f19d9da65593aed43354d05ceeec SHA512 eb365950d2eb62c8d984146228c7d96fca96b2ab4ea90b951a85b3f450550451e6c014da21e403476435e71c5ae989f169d21e07c56fab9713dacec0aee3184f
AUX pytz-2018.4-zoneinfo-noinstall.patch 579 BLAKE2B 1d21d01160dbdf6c6848c2c0088cbc6ca326270b106098ce7157b363acf6f4da750a58498be95a8b5bf1ee342b679fdbbf16cf9d542d5f46088062db83f866f7 SHA512 309c2427f5a8ebb77bdf899ad3fb34029c46901cbaf2baf3ab697b83608dd1d3c6e7cf776b1b9b592918b91cbafd148ee3e4c0b4255f38ea3e41c0bca94f4c51
+AUX pytz-2020.5-system-zoneinfo.patch 1294 BLAKE2B 0f6f4cf1c588b90827decb19d82d7adf97f44769b2acd4038d6b818ae27162f576338b61de6775b4aa387b4a1cb434b36d6f14fdf1eaa3c878e2af7e9ce32620 SHA512 aad785a23a3681de7d52c4898eae4d7f33ddff9c136f52111ab0aef076d0a3c72c7b0aa0910e191f3098baa05c09f522e927a94967481a89d1d1bcbe99824e3b
DIST pytz-2020.4.tar.gz 310941 BLAKE2B 8abe524ccb7ed676c64dbc129ade5d6562980ea28f8939a3a7a406acf16a8a936e79ff630bf37884610e8936dfe96311ecb752f3b79519a126e1f1ac48883842 SHA512 dcbe763bc6e48c52df855fe03a8109dc0656a0e851324c0468f4307e8aff60e577fe0c9f0b062319e90d2f639b96e98edf8346064705e244143386c863a0aa7c
+DIST pytz-2020.5.tar.gz 314194 BLAKE2B c374e0ee803878ad2dde1ef03c108f59f431d645d8067fb9f183b9feb029b4de283477e7f6c146a6d03462bd5cb4fc98118e03601c838f73903f5f7a7d28bf8f SHA512 0845c0b7cefb8732e3016568b17ae73232fe6537bac6da89cb1bf911ba5786ee1be6b5e3aa8767225291e3a7e9afd5b8e40e4051671a3a006f9e2f71c551e13e
EBUILD pytz-2020.4.ebuild 956 BLAKE2B aa4175ab3af316a62ce0a35ca83690aa048f2bae6afc38b4ee49d85f8b0b6d09ac4b3c55f56bd37df1aaf494c5d229228fe905b10ede85f1c1d11e5b038bd38e SHA512 657dd3ad35ba163bf5f8b32752f8fd18bbad0841231308b6dfed3818c6df1804530a2ce471b85b0ff14738cf41308e918f92636a102c14f44f3e65c394535e82
+EBUILD pytz-2020.5.ebuild 885 BLAKE2B e8ea3b7b466584a0f058f08d6db013cea2b406f708223b5748cba9637f4d0ff05411ea616bc28b8fc721848cf709ae6a11b9a9131cf4b432544434d0390f7017 SHA512 9af034faf83efe71817ade212fcc69641ee0cba46ecf6884aa5d5c40a2025b614666a7a294428f99272bd55e5b4dc758c8f06c8907a58328834019d9168ace9d
MISC metadata.xml 764 BLAKE2B d26c3334bd7cf99b7a8a7767def5d9ec82ee6e335e27aaf891a47c5037eeb2816457974ea99a1cc865359718a5d7fc30e41f68d8b7ecc82a7a7e87b5943c10ed SHA512 6160a54921cc7c8f7dd504121b359727ab14ef9277bdb96720a31c8e32d223d29080cf9eb76531a94da8a5c7752372938fa5760e4e6cc77118a4792c31813580
diff --git a/dev-python/pytz/files/pytz-2020.5-system-zoneinfo.patch b/dev-python/pytz/files/pytz-2020.5-system-zoneinfo.patch
new file mode 100644
index 000000000000..94bad7e234ac
--- /dev/null
+++ b/dev-python/pytz/files/pytz-2020.5-system-zoneinfo.patch
@@ -0,0 +1,33 @@
+diff --git a/pytz/__init__.py b/pytz/__init__.py
+index a1f75b6..f2a2330 100644
+--- a/pytz/__init__.py
++++ b/pytz/__init__.py
+@@ -92,8 +92,7 @@ def open_resource(name):
+ if zoneinfo_dir is not None:
+ filename = os.path.join(zoneinfo_dir, *name_parts)
+ else:
+- filename = os.path.join(os.path.dirname(__file__),
+- 'zoneinfo', *name_parts)
++ filename = os.path.join('/usr/share/zoneinfo', *name_parts)
+ if not os.path.exists(filename):
+ # http://bugs.launchpad.net/bugs/383171 - we avoid using this
+ # unless absolutely necessary to help when a broken version of
+diff --git a/setup.py b/setup.py
+index e31ff2b..ba6926b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -15,14 +15,8 @@ me = 'Stuart Bishop'
+ memail = 'stuart@stuartbishop.net'
+ packages = ['pytz']
+ resources = ['zone.tab', 'locales/pytz.pot']
+-for dirpath, dirnames, filenames in os.walk(os.path.join('pytz', 'zoneinfo')):
+- # remove the 'pytz' part of the path
+- basepath = dirpath.split(os.path.sep, 1)[1]
+- resources.extend([os.path.join(basepath, filename) for filename in filenames])
+ package_data = {'pytz': resources}
+
+-assert len(resources) > 10, 'zoneinfo files not found!'
+-
+ setup(
+ name='pytz',
+ version=pytz.VERSION,
diff --git a/dev-python/pytz/pytz-2020.5.ebuild b/dev-python/pytz/pytz-2020.5.ebuild
new file mode 100644
index 000000000000..58a2cbcffbde
--- /dev/null
+++ b/dev-python/pytz/pytz-2020.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/pytz-2020.5-system-zoneinfo.patch
+)
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}