summaryrefslogtreecommitdiff
path: root/dev-python/pytrie/pytrie-0.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytrie/pytrie-0.3.1.ebuild')
-rw-r--r--dev-python/pytrie/pytrie-0.3.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pytrie/pytrie-0.3.1.ebuild b/dev-python/pytrie/pytrie-0.3.1.ebuild
new file mode 100644
index 000000000000..8ebd37d75307
--- /dev/null
+++ b/dev-python/pytrie/pytrie-0.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="PyTrie"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A pure Python implementation of the trie data structure"
+HOMEPAGE="https://github.com/gsakkis/pytrie/ https://pypi.org/project/PyTrie/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"