summaryrefslogtreecommitdiff
path: root/dev-python/pythran/pythran-0.14.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythran/pythran-0.14.0.ebuild')
-rw-r--r--dev-python/pythran/pythran-0.14.0.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pythran/pythran-0.14.0.ebuild b/dev-python/pythran/pythran-0.14.0.ebuild
index 0cfd10c37eba..8ae4f640ebee 100644
--- a/dev-python/pythran/pythran-0.14.0.ebuild
+++ b/dev-python/pythran/pythran-0.14.0.ebuild
@@ -23,7 +23,7 @@ S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~sparc ~x86"
RDEPEND="
dev-libs/boost
@@ -52,11 +52,18 @@ BDEPEND="
distutils_enable_tests pytest
src_configure() {
- cat >> setup.cfg <<-EOF
+ cat >> setup.cfg <<-EOF || die
[build_py]
no_boost = True
no_xsimd = True
EOF
+
+ if use test ; then
+ sed -i \
+ -e 's|blas=blas|blas=cblas|' \
+ -e 's|libs=|libs=cblas|' \
+ pythran/pythran-*.cfg || die
+ fi
}
python_test() {