summaryrefslogtreecommitdiff
path: root/dev-python/pythran/pythran-0.11.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythran/pythran-0.11.0.ebuild')
-rw-r--r--dev-python/pythran/pythran-0.11.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/pythran/pythran-0.11.0.ebuild b/dev-python/pythran/pythran-0.11.0.ebuild
deleted file mode 100644
index 05448449ad1d..000000000000
--- a/dev-python/pythran/pythran-0.11.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..10} )
-inherit distutils-r1 multiprocessing
-
-MY_P=${P/_p/.post}
-DESCRIPTION="Ahead of Time compiler for numeric kernels"
-HOMEPAGE="
- https://pypi.org/project/pythran/
- https://github.com/serge-sans-paille/pythran/"
-SRC_URI="
- https://github.com/serge-sans-paille/pythran/archive/${PV/_p/.post}.tar.gz
- -> ${MY_P}.gh.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ppc ppc64 ~riscv ~sparc x86"
-
-RDEPEND="
- =dev-python/beniget-0.4*[${PYTHON_USEDEP}]
- =dev-python/gast-0.5*[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/ply-3.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/wheel[${PYTHON_USEDEP}]
- virtual/cblas
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.10.0-tests-werror.patch
-)
-
-src_prepare() {
- sed -i -e '/pytest-runner/d' setup.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x COLUMNS=80
- epytest -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
-}