summaryrefslogtreecommitdiff
path: root/dev-python/pythonz-bd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythonz-bd')
-rw-r--r--dev-python/pythonz-bd/Manifest3
-rw-r--r--dev-python/pythonz-bd/metadata.xml15
-rw-r--r--dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild24
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pythonz-bd/Manifest b/dev-python/pythonz-bd/Manifest
new file mode 100644
index 000000000000..3c591fb061a8
--- /dev/null
+++ b/dev-python/pythonz-bd/Manifest
@@ -0,0 +1,3 @@
+DIST pythonz-bd-1.11.4.tar.gz 86065 BLAKE2B 1b7710129a6c764693cf3092725e78a7f6321ecf1bd0323644f421ee4f1c3c1a1b6defb805fbb137e58001c9869d9fe9d124978d60127a6672bb54903fd2027b SHA512 de945a1a49094eb6f4f1d0a2dbab4d5e73b60eb4a5d5461c4368fd46e05bf97df7177f7bcecfe963600016f9641e4233ace15a2c231f658ed8eeb771ddb51ab7
+EBUILD pythonz-bd-1.11.4.ebuild 661 BLAKE2B 942efa4ffd8bba78b976fa5c364e658375b3cccde591094e74dadc37ecd795a18207c6789d3d12362527bfcab5cc3bff6664a4c8d7c434fa66cc55fa76bfe821 SHA512 a108f6b9122c408fbf252b0a6b6381c769d5f351ccadd08f31e9da303956df8c44c657b1b4b9f9d6309acd8c23cff989bcbcd06fe6bf7d3b4b630108dea2ed9a
+MISC metadata.xml 439 BLAKE2B e9935c2cf2df4194b736a7d1a8ebaf53780289ccc7ebe2d02c0128e0b298c78f920602f25cddf052af016dba1c9218acd98576fe87874c2fc73241ed5f3c036f SHA512 e3d98902122dd0d5f99e139d58ed62f1291a606eb399c0531936d69e72b855a51bc1475998b7910b5773621ff7fd366253ed7e911ffa40ad61fc18c945f006d9
diff --git a/dev-python/pythonz-bd/metadata.xml b/dev-python/pythonz-bd/metadata.xml
new file mode 100644
index 000000000000..2d6e2eed10d6
--- /dev/null
+++ b/dev-python/pythonz-bd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pythonz-bd</remote-id>
+ <maintainer status="unknown">
+ <email>saghul@gmail.com</email>
+ <name>saghul</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild b/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild
new file mode 100644
index 000000000000..c0305e3b77c5
--- /dev/null
+++ b/dev-python/pythonz-bd/pythonz-bd-1.11.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Manage python installations in your system, berdario's shallow fork"
+HOMEPAGE="
+ https://github.com/berdario/pythonz/tree/bd
+ https://pypi.python.org/pypi/pythonz-bd"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/resumable-urlretrieve[${PYTHON_USEDEP}]' 'python3*')"