summaryrefslogtreecommitdiff
path: root/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythonfinder/pythonfinder-2.0.6.ebuild')
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.0.6.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild b/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
deleted file mode 100644
index a7d99c9760e4..000000000000
--- a/dev-python/pythonfinder/pythonfinder-2.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
-HOMEPAGE="
- https://github.com/sarugaku/pythonfinder/
- https://pypi.org/project/pythonfinder/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~riscv"
-
-RDEPEND="
- >=dev-python/pydantic-2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/click[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # based on the patch from Arch
- # https://gitlab.archlinux.org/archlinux/packaging/packages/python-pythonfinder/-/blob/main/python-pythonfinder-2.0.5-pydantic2.patch
- "${FILESDIR}"/pythonfinder-2.0.6-pydantic-2.patch
-)
-
-python_test() {
- epytest -o addopts=
-}