summaryrefslogtreecommitdiff
path: root/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch')
-rw-r--r--dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch b/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
deleted file mode 100644
index 6b3840361bed..000000000000
--- a/dev-python/pythonfinder/files/pythonfinder-2.0.6-pydantic-2.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/pyproject.toml b/pyproject.toml
-index 73a3c85..27c9a7e 100644
---- a/pyproject.toml
-+++ b/pyproject.toml
-@@ -39 +39 @@ dependencies = [
-- "pydantic>=1.10.7,<2",
-+ "pydantic>=2",
-@@ -140 +140 @@ runtime-evaluated-base-classes = [
-- "pydantic.BaseModel",
-+ "pydantic.v1.BaseModel",
-diff --git a/src/pythonfinder/models/common.py b/src/pythonfinder/models/common.py
-index 4c439c9..0ef3d77 100644
---- a/src/pythonfinder/models/common.py
-+++ b/src/pythonfinder/models/common.py
-@@ -3 +3 @@ from __future__ import annotations
--from pydantic import BaseModel, Extra
-+from pydantic.v1 import BaseModel, Extra
-diff --git a/src/pythonfinder/models/mixins.py b/src/pythonfinder/models/mixins.py
-index 58ce99a..e68020f 100644
---- a/src/pythonfinder/models/mixins.py
-+++ b/src/pythonfinder/models/mixins.py
-@@ -15 +15 @@ from typing import (
--from pydantic import BaseModel, Field, validator
-+from pydantic.v1 import BaseModel, Field, validator
-diff --git a/src/pythonfinder/models/path.py b/src/pythonfinder/models/path.py
-index fe98054..beb88be 100644
---- a/src/pythonfinder/models/path.py
-+++ b/src/pythonfinder/models/path.py
-@@ -26 +26 @@ else:
--from pydantic import Field, root_validator
-+from pydantic.v1 import Field, root_validator
-diff --git a/src/pythonfinder/models/python.py b/src/pythonfinder/models/python.py
-index c5e0345..32c82a8 100644
---- a/src/pythonfinder/models/python.py
-+++ b/src/pythonfinder/models/python.py
-@@ -22 +22 @@ from packaging.version import Version
--from pydantic import Field, validator
-+from pydantic.v1 import Field, validator