summaryrefslogtreecommitdiff
path: root/dev-python/python3-xapp/python3-xapp-2.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python3-xapp/python3-xapp-2.2.2.ebuild')
-rw-r--r--dev-python/python3-xapp/python3-xapp-2.2.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python3-xapp/python3-xapp-2.2.2.ebuild b/dev-python/python3-xapp/python3-xapp-2.2.2.ebuild
new file mode 100644
index 000000000000..63cbe7e119ba
--- /dev/null
+++ b/dev-python/python3-xapp/python3-xapp-2.2.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for x11-libs/xapp"
+HOMEPAGE="https://github.com/linuxmint/python3-xapp"
+SRC_URI="https://github.com/linuxmint/python3-xapp/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ >=x11-libs/xapp-2.2.0[introspection]
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/psutil[${PYTHON_USEDEP}]
+"