summaryrefslogtreecommitdiff
path: root/dev-python/python-zeroconf
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-zeroconf')
-rw-r--r--dev-python/python-zeroconf/Manifest7
-rw-r--r--dev-python/python-zeroconf/metadata.xml13
-rw-r--r--dev-python/python-zeroconf/python-zeroconf-0.39.1.ebuild51
-rw-r--r--dev-python/python-zeroconf/python-zeroconf-0.39.2.ebuild51
-rw-r--r--dev-python/python-zeroconf/python-zeroconf-0.39.3.ebuild49
5 files changed, 171 insertions, 0 deletions
diff --git a/dev-python/python-zeroconf/Manifest b/dev-python/python-zeroconf/Manifest
new file mode 100644
index 000000000000..26a56ef4f785
--- /dev/null
+++ b/dev-python/python-zeroconf/Manifest
@@ -0,0 +1,7 @@
+DIST python-zeroconf-0.39.1.gh.tar.gz 135252 BLAKE2B 82efa3e39b6e18b9d73b45958190c1d76978231842c1f61ff4519b9a763fb2c1564dae9c0b1d31109e291acc966127cfae9fa02400f1695e97dcc1b0e5a509f7 SHA512 3e1bc4bd48b77bce711f8b49b9cdce1769d7af72094c9ebc161ecb833fe90c7bd36ec5b9fc35c524ddd8c30a67af5937f188c81cf3a251d80c0e71f4b7c3add7
+DIST python-zeroconf-0.39.2.gh.tar.gz 136788 BLAKE2B ce8130cd3b89969e0cb5a9e9ddc82dc29e2517a29ce44f309950034ece433475336647dcebef8d6ec0d68271b784f9a345d2fb752dc0ad185db0298cfbad4bdd SHA512 0e1f5abdb5ed82bd281353c7bd84eeabd160195d66d641a4ce97f5f4806aab9bcf1c4cdf399e1a8082ac9b7ad979151bfc03b2b6226744075b2025fceaa30c79
+DIST python-zeroconf-0.39.3.gh.tar.gz 137044 BLAKE2B df2ba0b21902296e77fc20ff006872995efc378898d381e61e5f366f27e2532cedbd9482675f8aa163e258b68e0b33d2134783ca1c72a7fee52a209ac821f185 SHA512 3d76b88fed2db3674e3319e27fc85a036ae9d990bea2cf369cbd5853b416fad8315e156d6a7c5f025d09ba069675c4be53c34f9b021d05bff04422ea9101e6a0
+EBUILD python-zeroconf-0.39.1.ebuild 1417 BLAKE2B 1d9d3c3806b0a9eab051ca6949490ddb5f8d3564fa70410cbc364303d2ded7a03af63133fbc958129ec133e6d0a18bc0919e5f69a69913b24a19cc5d250f8c24 SHA512 f0cdf656eca561ba59804b72cfce5657f4f4af91421b150ab0b7a4256e3b978749c75cfa62e5f157eb4ef30d0dedecd6cb9d9729572ecd2ca9f6a026d8dd9a35
+EBUILD python-zeroconf-0.39.2.ebuild 1419 BLAKE2B c058ed83251c9b6e71b7a0993da082b946c1639325535b64d799d234358ad2b4bd9cf9dcfa0370ba176e9df60dd8f0b37718eb9aac1a3892c03427a00e01ebf9 SHA512 6e4b958f26ea2f78a4bd3e7e5561af332d2b6eb376290cd2ff2b71c666a9a5085e24a8e077471e330d8bdf5b961ca45557d2454c30c5aa4aa4c4de2567125f52
+EBUILD python-zeroconf-0.39.3.ebuild 1366 BLAKE2B aeee01b5f7837cb9e8eb284998b314cfa9ab05554289e3dce2c67fe1f6cf2504dbf8b15d3db0d1a508783ada6a5fa023256109cbae418b8a3b74f0773a6520db SHA512 356c19f6216a8c57f37c549fcb995887927b70a8be0b67029b9024e39899e48561eb1c97164605fd5517a27f15c6817791b5a2fe24fb0e5d2702082cc8ffefab
+MISC metadata.xml 413 BLAKE2B f93eceda07029400d2fd7ab38f234e5a1747e3d86f228adc973bbd6cdc71456778a7d926457f976cb2c6f55678b2c671d2415e5c7a480306582f1e70f6f733dc SHA512 d228e198b2f495dd02cd3d9d948aae123461c70c8e0185a47b133000f0316a84ff33d9b6f4cc0196bca5cf638e53ae58a3cd746338c33729d957a1170a5f08dd
diff --git a/dev-python/python-zeroconf/metadata.xml b/dev-python/python-zeroconf/metadata.xml
new file mode 100644
index 000000000000..c1970e1e2792
--- /dev/null
+++ b/dev-python/python-zeroconf/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">zeroconf</remote-id>
+ <remote-id type="github">jstasiak/python-zeroconf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-zeroconf/python-zeroconf-0.39.1.ebuild b/dev-python/python-zeroconf/python-zeroconf-0.39.1.ebuild
new file mode 100644
index 000000000000..efc857219ad0
--- /dev/null
+++ b/dev-python/python-zeroconf/python-zeroconf-0.39.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)
diff --git a/dev-python/python-zeroconf/python-zeroconf-0.39.2.ebuild b/dev-python/python-zeroconf/python-zeroconf-0.39.2.ebuild
new file mode 100644
index 000000000000..e803d214a211
--- /dev/null
+++ b/dev-python/python-zeroconf/python-zeroconf-0.39.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)
diff --git a/dev-python/python-zeroconf/python-zeroconf-0.39.3.ebuild b/dev-python/python-zeroconf/python-zeroconf-0.39.3.ebuild
new file mode 100644
index 000000000000..3271b3e2ac15
--- /dev/null
+++ b/dev-python/python-zeroconf/python-zeroconf-0.39.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-4.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)