summaryrefslogtreecommitdiff
path: root/dev-python/python-termstyle
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-termstyle')
-rw-r--r--dev-python/python-termstyle/Manifest4
-rw-r--r--dev-python/python-termstyle/files/tests-unicode.patch10
-rw-r--r--dev-python/python-termstyle/metadata.xml9
-rw-r--r--dev-python/python-termstyle/python-termstyle-0.1.10.ebuild36
4 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/python-termstyle/Manifest b/dev-python/python-termstyle/Manifest
deleted file mode 100644
index acf22f4f8db0..000000000000
--- a/dev-python/python-termstyle/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX tests-unicode.patch 212 BLAKE2B 0c4d38d0fbdf3871cc81741f0f4533fd989b9636f5d9f435230a154b33d9fabdc5c3ec135f8168a4be1d9f990767871cea8ad19b3f8c6af7e5ab7ca9f9c07500 SHA512 cdb60f341dd186febe72e09586a7b1d65087c0773b1192d9725188cfa4b9bae902026ec7bb723359863695e08992b2b5bae2a25d7aed0c2018dd22dadb8b850b
-DIST python-termstyle-0.1.10.tar.gz 5025 BLAKE2B af652f560f3c6657ca01080cdaece77af7a1ecdf0758cf777035427197142b04a7d39a249da6eee90dc06cc2d15ca484c8b1d086c8e32e761acb8adc0eeccf3f SHA512 a0ed484da8da10c7fe1b8422a26861fb115dc29c49ce79c113053f913d3371edf6222de1ccf40e6aa34c3cfa9da5805eb3928fb07bfae18a13683621d7547743
-EBUILD python-termstyle-0.1.10.ebuild 836 BLAKE2B ca4e2725d3395a91ade5cf7b219092eb5f8578fc57ecd57026a5cfd815253965eb92c4b7ab6ebde25fc804d0fb021ad0c84c42ce8f042ec76f423060d6e04593 SHA512 e6162004e01613c33e4fa54e829f2af9b5fc7062b01e64868f36162abbd8c01ed0a8f4b49095c52412d09881c22d27d572a1028dc3f2c1ac0202c2942e47a760
-MISC metadata.xml 304 BLAKE2B c24d14f929d11fed58ffb169c73d27f6e3da29d18e7f8f57909b483611ca2efc438791ca859a48f51d8a9fcdfae433e5ccc8fc13ae107b7087f5c1bfd982a416 SHA512 2f9d120ec9c512d1246e8feacbad1fccb9a82d906e1a2b2fe80a663eaa0554065da9816e8fe6b67a99afbc2b9248b870174927756b9c8f7968bb3ef93c34d91a
diff --git a/dev-python/python-termstyle/files/tests-unicode.patch b/dev-python/python-termstyle/files/tests-unicode.patch
deleted file mode 100644
index 4cb410fa1984..000000000000
--- a/dev-python/python-termstyle/files/tests-unicode.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff --git a/test2.py b/test2.py
-index 2d84c37..1331545 100755
---- a/test2.py
-+++ b/test2.py
-@@ -2,4 +2,4 @@
-
- from termstyle import *
-
--print green(u"unicod\xe9!")
-+print green(u"unicod\xe9!".encode('utf-8'))
diff --git a/dev-python/python-termstyle/metadata.xml b/dev-python/python-termstyle/metadata.xml
deleted file mode 100644
index 7aceef00ef01..000000000000
--- a/dev-python/python-termstyle/metadata.xml
+++ /dev/null
@@ -1,9 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!--maintainer-needed-->
- <upstream>
- <remote-id type="github">timbertson/termstyle</remote-id>
- <remote-id type="pypi">python-termstyle</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild b/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
deleted file mode 100644
index 1945a11446e8..000000000000
--- a/dev-python/python-termstyle/python-termstyle-0.1.10.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="console colouring for python"
-HOMEPAGE="http://gfxmonk.net/dist/0install/python-termstyle.xml"
-SRC_URI="https://github.com/timbertson/${PN#*-}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/termstyle-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc64 x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-python_prepare_all() {
- local PATCHES=(
- "${FILESDIR}"/tests-unicode.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if [[ "${EPYTHON}" = "python2.7" ]]; then
- "${PYTHON}" test2.py || die "test2.py failed under ${EPYTHON}"
- else
- "${PYTHON}" test3.py || die "test3.py failed under ${EPYTHON}"
- fi
-}