summaryrefslogtreecommitdiff
path: root/dev-python/python-systemd/python-systemd-234.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-systemd/python-systemd-234.ebuild')
-rw-r--r--dev-python/python-systemd/python-systemd-234.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-systemd/python-systemd-234.ebuild b/dev-python/python-systemd/python-systemd-234.ebuild
new file mode 100644
index 000000000000..978b842ca4bc
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-234.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ sys-apps/systemd:0=
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+RDEPEND="${COMMON_DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+# "${FILESDIR}"/233-xfail-bind.patch
+)
+
+python_test() {
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ pytest -o cache_dir="${T}" -vv || die
+ popd > /dev/null || die
+}