summaryrefslogtreecommitdiff
path: root/dev-python/python-swiftclient
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-swiftclient')
-rw-r--r--dev-python/python-swiftclient/Manifest2
-rw-r--r--dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-swiftclient/Manifest b/dev-python/python-swiftclient/Manifest
index a0d74e8781eb..96f275d5c312 100644
--- a/dev-python/python-swiftclient/Manifest
+++ b/dev-python/python-swiftclient/Manifest
@@ -1,3 +1,5 @@
DIST python-swiftclient-4.2.0.tar.gz 203334 BLAKE2B 5c64c785b8d3db45c5d89d3c09f27d0caa7a7f7a57afd935c2f10b050882734e966eb5b027bc956b450a19e6aa5d6ed2ad955db556b83a1086ac358d1c82025c SHA512 8426f39a5d37281816570c13491da1f459fe03182a8041fbd362733376d0c7edda6b51e4d3bbcb5ceed79ec7746e127760d1f936326b50a1cc7de102590f45d7
+DIST python-swiftclient-4.3.0.tar.gz 206510 BLAKE2B 6a3683ffbe09905d310dabac5d1d3926125d85b8383e487d916df00e91621bc1bc901ed2ceed23a9ef4ecaf81e86f2560f77f20751a2b8c3ca543114ea5fa3d8 SHA512 8c113122b1dec2eb901b7256b0b5c9e6e3e11959ebdda28f512dd84b0370dcf8e7299594f50649c147526b4076baabf2a0fe6f6f433193d4c198890265f57807
EBUILD python-swiftclient-4.2.0.ebuild 1138 BLAKE2B 4332fd63e876d80e2d2a2497c5ef74de2687d8e07c28b044f892a130b375c891c8d9c69f5ce9fc33c05e60a71a1aad5d75e0f713994b1088b1938dabddc92435 SHA512 4dad500e323c271d818b5288b132c739696fbff83a590a85ff546750887f8bb1842cf713246ba85ae369d0d12a3130befc3113c402060e4019ec5261d24dddfa
+EBUILD python-swiftclient-4.3.0.ebuild 1140 BLAKE2B d247869a5f351ad502c5cad65548a1f6216a7351c0eac0055b303d9cbd87c7520547f61e8ef444780b1a5d79915f89a7dedfe483a48fd38b5c72cb6ad837c325 SHA512 566b396522304c63b7f5893d9bdcd8529a8b4d0968ed6e975a70d383a5ef4977e245c52b52e46b412db2be8054e272ab838b1bf58371d5a0141a6070b6b70cfc
MISC metadata.xml 668 BLAKE2B 299614e07d6b3f2d4acbc301cfddff8c1699acf3dac104de483e9dafdbf4cb34c8b933fdf7d91de3c26e73f34165338f68b46a44f3a113eb68b9b0270b9819c2 SHA512 f8b012262d487c873552beffe7107c8799bff52b6c61da575a9b2fa82d899d4e30d3a57f0885a119d8aebe87d5be61ea846d0766a409396acaa5fdb2b632e248
diff --git a/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild b/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild
new file mode 100644
index 000000000000..edccb0e1001c
--- /dev/null
+++ b/dev-python/python-swiftclient/python-swiftclient-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python bindings to the OpenStack Object Storage API"
+HOMEPAGE="
+ https://opendev.org/openstack/python-swiftclient/
+ https://github.com/openstack/python-swiftclient/
+ https://pypi.org/project/python-swiftclient/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/keystoneauth1-3.4.0[${PYTHON_USEDEP}]
+ dev-python/python-keystoneclient[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openstacksdk-0.11.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -e 's/test_password_prompt/_&/' -i test/unit/test_shell.py || die
+ # fix duplicate script/entry point
+ # https://bugs.launchpad.net/python-swiftclient/+bug/1975361
+ sed -i -e '/bin\/swift/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}