summaryrefslogtreecommitdiff
path: root/dev-python/python-slugify/python-slugify-8.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-slugify/python-slugify-8.0.2.ebuild')
-rw-r--r--dev-python/python-slugify/python-slugify-8.0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/python-slugify/python-slugify-8.0.2.ebuild b/dev-python/python-slugify/python-slugify-8.0.2.ebuild
new file mode 100644
index 000000000000..53b7da22bd82
--- /dev/null
+++ b/dev-python/python-slugify/python-slugify-8.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python Slugify application that handles Unicode"
+HOMEPAGE="
+ https://github.com/un33k/python-slugify/
+ https://pypi.org/project/python-slugify/
+"
+SRC_URI="
+ https://github.com/un33k/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/text-unidecode[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest