summaryrefslogtreecommitdiff
path: root/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild')
-rw-r--r--dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild b/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
new file mode 100644
index 000000000000..e77a89547183
--- /dev/null
+++ b/dev-python/python-recaptcha/python-recaptcha-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin for reCAPTCHA and reCAPTCHA Mailhide"
+HOMEPAGE="https://github.com/redhat-infosec/python-recaptcha"
+SRC_URI="https://github.com/redhat-infosec/python-recaptcha/releases/download/v${PV}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ !dev-python/recaptcha-client"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install() {
+ distutils-r1_python_install
+ # otherwise we have an empty recaptcha dir/namespace
+ touch "${D}$(python_get_sitedir)"/recaptcha/__init__.py
+}