summaryrefslogtreecommitdiff
path: root/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild')
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild b/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
deleted file mode 100644
index 53464d743d9b..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.9.8-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="A Python binding of ptrace library"
-HOMEPAGE="https://github.com/vstinner/python-ptrace"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/vstinner/python-ptrace"
-else
- SRC_URI="https://github.com/vstinner/python-ptrace/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- KEYWORDS="amd64 x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="${PYTHON_DEPS}
- dev-python/six[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}/${P}-python3_12.patch"
-)
-
-distutils_enable_tests pytest
-
-src_test() {
- ./runtests.py --tests tests/ || die
-}