summaryrefslogtreecommitdiff
path: root/dev-python/python-podman
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-podman')
-rw-r--r--dev-python/python-podman/Manifest4
-rw-r--r--dev-python/python-podman/metadata.xml4
-rw-r--r--dev-python/python-podman/python-podman-3.2.0.ebuild44
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/python-podman/Manifest b/dev-python/python-podman/Manifest
index 537499301b7b..1231e1621af2 100644
--- a/dev-python/python-podman/Manifest
+++ b/dev-python/python-podman/Manifest
@@ -1,3 +1,5 @@
+DIST podman-py-3.2.0.tar.gz 165514 BLAKE2B 7e25d160b98e45cc147069249d850b3a3d6dac5227942d90ed99b8313befd9db04a6423015ae56959a53eeeb49958d9067eb6fb7127ee55bf50ebfcea617a220 SHA512 8ef165847de5fecd81e7b5564baeaa0298efd4d2e6f12e1dfe958eed77f945d9375d90ba93a8ebab4b090b228d451e96ce49d08288dc3daae1255a05127b25c7
DIST python-podman-1.6.0.tar.gz 28733 BLAKE2B ef36b80d99be07def311c2a8574cc36131760b39f0c80fb8707fb99ec9c2234e297724fc662f936217f9c2ec24fed0f57fd680702fbbac0e8411fc7c90da0577 SHA512 e7d730f8cfef0944df82ee73edb858e3cfd76a91dace98a2638341a1eb3ba5b9076d52f2f634cb4a94e082a83553412cdb1c5b79041d5bf4615998d67bb4a03f
EBUILD python-podman-1.6.0.ebuild 823 BLAKE2B f53c3b33eaab6ef349942cd7a293a91f11b1902d4dc9f7c011b01770de58079bbc7d9dd1716b9e5dfd86fca7a7acbefa30040eea05218e5cc67f47e4ced00ee5 SHA512 406df830e9a0d9d57beb33df9267fd103be8353cd7ff2925c04deb1f575857818b85f9009da4af473ccbbfd424bdf66f0eb3192d9da8133968a36779bc29e8fe
-MISC metadata.xml 377 BLAKE2B 75e5283150b5ef215448569254a4707ed648adc52a99664775fb21e1d49c4a0af6b6b559c5829aa759a20412a0f36b73a28b3375e5310b76a2648652e82e6fce SHA512 db373251d8bcd61548e6f173f071b399f93f253d311195f74ee2a07ac0440d934a7b5a1f838a8629f986dc6032780a5bc0be3b6665127d610fd7fd28586f143f
+EBUILD python-podman-3.2.0.ebuild 1044 BLAKE2B a9e0fb891cac4ef6fd2a973df6d0472a868ba45966f76360a93a4a924535be7abf9086797106ac6f195c0d0539617478489e5fc831a5261097198516651564b1 SHA512 f21cf86bbb0f9fbefe1a31294638df3a3f2678c1935d8d47605b32a5a245f6b27136e179dfb9905fc0b243caab93d8db49b3b7c3249bc9f19c5cae0a6174d2f0
+MISC metadata.xml 478 BLAKE2B a5456f4437b36f5720e217997a25f414eda48247d6720cb67b43034e1eb9748d1058c818aafc5ee342f7c4aec7789c2706c05fefd321d8f74bec475125af00e0 SHA512 c2513eb754a47f0c4e72cfdbbd3cfdded27fbcea247439531a3ac5ff74b7f346d2f9a03a17a4fb8fca8853b76c979eddddf4800d322404a9a9ccc1a8e6dbcdf5
diff --git a/dev-python/python-podman/metadata.xml b/dev-python/python-podman/metadata.xml
index 1264cba62cca..345f5fb9555a 100644
--- a/dev-python/python-podman/metadata.xml
+++ b/dev-python/python-podman/metadata.xml
@@ -5,6 +5,10 @@
<email>zmedico@gentoo.org</email>
<name>Zac Medico</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<upstream>
<remote-id type="github">containers/python-podman</remote-id>
<remote-id type="pypi">podman</remote-id>
diff --git a/dev-python/python-podman/python-podman-3.2.0.ebuild b/dev-python/python-podman/python-podman-3.2.0.ebuild
new file mode 100644
index 000000000000..58c9d7fd927b
--- /dev/null
+++ b/dev-python/python-podman/python-podman-3.2.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+MY_P=podman-py-${PV}
+DESCRIPTION="A library to interact with a Podman server"
+HOMEPAGE="
+ https://github.com/containers/podman-py/
+ https://pypi.org/project/podman/"
+SRC_URI="
+ https://github.com/containers/podman-py/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # TODO
+ podman/tests/unit/test_volumesmanager.py::VolumesManagerTestCase::test_get_404
+ )
+
+ # integration tests require a workable podman server,
+ # and it doesn't seem to work in ebuild env
+ epytest podman/tests/unit ${deselect[@]/#/--deselect }
+}