summaryrefslogtreecommitdiff
path: root/dev-python/python-netlink/python-netlink-0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-netlink/python-netlink-0.1.ebuild')
-rw-r--r--dev-python/python-netlink/python-netlink-0.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-netlink/python-netlink-0.1.ebuild b/dev-python/python-netlink/python-netlink-0.1.ebuild
new file mode 100644
index 000000000000..3ce39a389a6c
--- /dev/null
+++ b/dev-python/python-netlink/python-netlink-0.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="NetLink"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Pure-Python client for the Linux NetLink interface"
+HOMEPAGE="https://pypi.org/project/NetLink/ https://xmine128.tk/Software/Python/netlink/docs/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="!dev-libs/libnl[python]"
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # setuptools-markdown is not needed.
+ sed -e "s:'setuptools-markdown'::" -i setup.py || die
+}