summaryrefslogtreecommitdiff
path: root/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-markdown-math/python-markdown-math-0.6.ebuild')
-rw-r--r--dev-python/python-markdown-math/python-markdown-math-0.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild b/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild
new file mode 100644
index 000000000000..2beab8d6d704
--- /dev/null
+++ b/dev-python/python-markdown-math/python-markdown-math-0.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+inherit distutils-r1
+
+MY_PN="python-${PN}"
+
+DESCRIPTION="Math extension for Python-Markdown"
+HOMEPAGE="https://github.com/mitya57/python-markdown-math"
+
+if [[ ${PV} == *9999 ]]
+ then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mitya57/python-markdown-math.git"
+ else
+ SRC_URI="mirror://pypi/${MY_PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+python_test(){
+ esetup.py test
+}