summaryrefslogtreecommitdiff
path: root/dev-python/python-magic/python-magic-0.4.15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.15.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.15.ebuild7
1 files changed, 2 insertions, 5 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.15.ebuild b/dev-python/python-magic/python-magic-0.4.15.ebuild
index 272c99c42619..1abf74ba9369 100644
--- a/dev-python/python-magic/python-magic-0.4.15.ebuild
+++ b/dev-python/python-magic/python-magic-0.4.15.ebuild
@@ -9,7 +9,7 @@ inherit distutils-r1
DESCRIPTION="Access the libmagic file type identification library"
HOMEPAGE="https://github.com/ahupp/python-magic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ahupp/python-magic/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="MIT"
SLOT="0"
@@ -20,9 +20,6 @@ RDEPEND="sys-apps/file[-python]"
DEPEND="${DEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
-# Needs MacOS python module, bug #659102
-RESTRICT="test"
-
python_test() {
- esetup.py test
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
}