summaryrefslogtreecommitdiff
path: root/dev-python/python-linux-procfs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-linux-procfs')
-rw-r--r--dev-python/python-linux-procfs/Manifest6
-rw-r--r--dev-python/python-linux-procfs/metadata.xml5
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild13
-rw-r--r--dev-python/python-linux-procfs/python-linux-procfs-0.7.3.ebuild27
4 files changed, 42 insertions, 9 deletions
diff --git a/dev-python/python-linux-procfs/Manifest b/dev-python/python-linux-procfs/Manifest
index 44dc0a814a55..eec0cd2f3ee5 100644
--- a/dev-python/python-linux-procfs/Manifest
+++ b/dev-python/python-linux-procfs/Manifest
@@ -1,3 +1,5 @@
DIST python-linux-procfs-0.7.1.tar.xz 19104 BLAKE2B e6e495ecce77c1ea4c1580c2534e87f769a0057702648ee75bf89f5cbaa944012ba17e69c231977889b9b18d8e9b8d67261361b499ef8a567bed978a207d61ec SHA512 532613cd0feab1317131a3ec30e0730ed48415de333f1430573b7bf0eb5525222dc92db38dab6ff76c27ff10ac0a381975c329441b9ca6011e79bd637482056d
-EBUILD python-linux-procfs-0.7.1.ebuild 715 BLAKE2B 3f3dcb13ef4a02f6b3ccabe5027917e28b1b06b2f81d70cdc72509b2edc613ec25c372fd4988bfab46ea2374cd243934a72c3c41f083b60e1a5671707f9152e9 SHA512 a1c55ca2b7dcec0b9d4eccb9b043b146b64b3cadd52bcee952983d6a81fab0f94f24552166ffe2b5ca11b7bf9f1c410c534e5bcad569d1d938ccade75387b969
-MISC metadata.xml 167 BLAKE2B 868e3b584722eaacf68273db062bb773d8c7e5d7ab2b81ca7e8397643bf7cc106c3a1033594401c99c54f667bb45d6b73f9048fc335580bbd44b4589ad26a832 SHA512 30caadd1496c3b9969136038239a1d8e01f236726b4022c2d7e19ca7575f25f735e556835e581afbf44fbd3e4104c40f2b5ef5fa70118d75c881fdf871962d0a
+DIST python-linux-procfs-0.7.3.tar.xz 11412 BLAKE2B 66c22261a3ab9fff68949e2e1e54a07ac5bc365d12e52b8149a02105e2ace85e22be38ec84fb1c97b3d4fec6392998d98252e11454a72135eacae770efa171ae SHA512 fbb4bd5b22ccafd6e8fed853f9bc175f9c7b5fc6795b9641a5e39404a96c1cdfdad7856fa89b3dc91ee9f13e3c76a23c79e3729fdfd7a10df1e46fdbb25aa631
+EBUILD python-linux-procfs-0.7.1.ebuild 651 BLAKE2B 43df0ce7f1ed350800364eeb12860ad235dc814ef423ea0fc8110336665c7a6155e8e1c9191118a3739d1a4dd634af8312bd81077ad26884502dfbe82daa5ea9 SHA512 c9725e3f438cca5a2010fdd2974433d8695234892269bf2417bf85af41e4f5f412def1bac59048288e0d6581c9b7e54be0ad9c8be7eb308789919f89629213e8
+EBUILD python-linux-procfs-0.7.3.ebuild 651 BLAKE2B 43df0ce7f1ed350800364eeb12860ad235dc814ef423ea0fc8110336665c7a6155e8e1c9191118a3739d1a4dd634af8312bd81077ad26884502dfbe82daa5ea9 SHA512 c9725e3f438cca5a2010fdd2974433d8695234892269bf2417bf85af41e4f5f412def1bac59048288e0d6581c9b7e54be0ad9c8be7eb308789919f89629213e8
+MISC metadata.xml 241 BLAKE2B 4f18c355c71824c25df283b2d463a5abbf2295446e74b960e868dd78d4910ac066725450478087567a6e66b7a8948d99e053f13a7e58dbf2b89fdaf5c2f3436c SHA512 c46e70ffd66754ad84c64806f2bbff25ba9a688f035176a4565afc95351ce10fffba64bbde89965501460b05978c7e59b3d84db6a8cb6efff4055d4b7a5ab5d8
diff --git a/dev-python/python-linux-procfs/metadata.xml b/dev-python/python-linux-procfs/metadata.xml
index 85e4ed814fa2..efd7c8c21836 100644
--- a/dev-python/python-linux-procfs/metadata.xml
+++ b/dev-python/python-linux-procfs/metadata.xml
@@ -1,5 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
</pkgmetadata>
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
index 89622b4136e5..741726f9f8c9 100644
--- a/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.7.1.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
HOMEPAGE="
- https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/
- https://kernel.googlesource.com/pub/scm/libs/python/python-linux-procfs/python-linux-procfs/
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/python-linux-procfs.git/
"
SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
@@ -19,8 +18,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
python_test() {
- ${EPYTHON} ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
+ "${EPYTHON}" ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
}
diff --git a/dev-python/python-linux-procfs/python-linux-procfs-0.7.3.ebuild b/dev-python/python-linux-procfs/python-linux-procfs-0.7.3.ebuild
new file mode 100644
index 000000000000..741726f9f8c9
--- /dev/null
+++ b/dev-python/python-linux-procfs/python-linux-procfs-0.7.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python classes to extract information from the Linux kernel /proc files"
+HOMEPAGE="
+ https://git.kernel.org/pub/scm/libs/python/python-linux-procfs/python-linux-procfs.git/
+"
+SRC_URI="https://cdn.kernel.org/pub/software/libs/python/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ "${EPYTHON}" ./bitmasklist_test.py || die "Tests failed with ${EPYTHON}"
+}